mediaIamge

You can search the firmware with the product serial number, and update your firmware to continue to protect and secure your equipment. Users can also use the Search Tool for Important Firmware Update to quickly detect critical vulnerabilities and download corresponding firmware.

 

Note: Only products affected by the vulnerability can be searched on the page. Your device firmware is affected by this security vulnerability (CVE-2021-36260) if its version dated earlier than 210628. Please contact Hikvision technical support if the firmware of affected products can't be found.

Firmware search
*
Please enter a valid serial number.
*
Upload
Only support Excel file, sample sheet
Only support to query less than 100 items once.
*
Please enter the valid verification code.
Loading...

This website uses necessary cookies to enable the website to function well. We would like to use additional cookies to provide you the best experience on our website. For more information, please see our cookie policy.

Contact Us
back to top
Top