Notification de sécurité - Vulnérabilité de débordement de tampon dans certaines caméras IP Hikvision

Notification de sécurité - Vulnérabilité de débordement de tampon dans certaines caméras IP Hikvision

SN No. HSRC-201808-01

Edit : HSRC (Centre de réponse de sécurité Hikvision) :

Date de sortie initiale : 13.08.2018

Date de mise à jour : 23.08.2018

résumé

Une vulnérabilité de dépassement de mémoire tampon dans le serveur Web de certaines caméras IP Hikvision permet à un attaquant d'envoyer un message spécialement conçu aux périphériques affectés. En raison d'une validation d'entrée insuffisante, une exploitation réussie peut corrompre la mémoire et entraîner l'exécution de code arbitraire ou bloquer le processus.  

ID CVE

CVE-2018-6414

Notation

CVSS v3 est adopté dans ce score de vulnérabilité (http://www.first.org/cvss/specification-document)

Notation de base : 8.9 (AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:H)

Score temporel 8.0 (E:P/RL:O/RC:C)

Versions et correctifs concernés

Caméra IP :

Nom du produit

Versions affectées

Versions corrigées

Où trouver mettre à jour le firmware

DS-2CD2xx5
DS-2CD2xx3

V5.5.0 build170725 à V5.5.52 build180511

V5.5.61 build180718  et ultérieur

Lien de téléchargement

DS-2CD3xxx

V5.5.0 build170725 à V5.5.60 build180515

V5.5.61 build180718  et ultérieur

Lien de téléchargement

DS-2CD1X43
DS-2CD1X53

V5.5.2 build170920 à V5.5.52 build180523

V5.5.53 build180716  et ultérieur

Lien de téléchargement

DS-2CD2X12FWD
DS-2CD2X22FWD
DS-2CD2X42FWD
DS-2CD2X52F

 

V5.5.0 build170725 à V5.5.52 build180427

 

V5.5.53 build180730  et ultérieur

Lien de téléchargement

DS-2CD4x26EFWD
DS-2CD4BxxFWD
DS-2CD4CxxFWD
DS-2CD4DxxFWD
DS-2XMxxxx

V5.5.0 build170914 à V5.5.52 build180601

V5.5.53 build180719  et ultérieur

Lien de téléchargement

DS-2CD1x01-I

V5.5.5 build180207 à V5.5.52 build180620

V5.5.53 build180717  et ultérieur

Lien de téléchargement

DS-2CD1x23

V5.5.2 build171013 à V5.5.52 build180522

V5.5.53 build180713  et ultérieur

Lien de téléchargement

DS-2CD1x21

V5.5.4 build180104 à V5.5.52 build180626

V5.5.53 build180717  et ultérieur

Lien de téléchargement

HiLook :

Nom du produit

Versions affectées

Versions corrigées

Où trouver mettre à jour le firmware

IPC-B100
IPC-D100

V5.5.5 build180207 à V5.5.52 build180620

V5.5.53 build180717  et ultérieur

Lien de téléchargement

IPC-x120H
IPC-T220H

V5.5.2 build171013 à V5.5.52 build180522

V5.5.53 build180713  et ultérieur

Lien de téléchargement

IPD* :

Nom du produit

Versions affectées

Versions corrigées

Où mettre à jour le firmware

DS-2DF5xxx
DS-2DF6xxx
DS-2DF7xxx
DS-2DF8xxx
DS-2DT6223

V5.5.2 build171201 et versions antérieures*

V5.5.71 build180723  et ultérieur

Lien de téléchargement

DS-2DE4xxxW
DS-2DE5xxxW
DS-2DE7xxxW

V5.5.6 build180408 et versions antérieures*

V5.5.71 build180725  et ultérieur

Lien de téléchargement

 

* Mise à jour du 23/08/2018: La version affectée d'IPD n'inclut pas la V5.4.0 et les versions précédentes. 

 

Obtention du firmware corrigé :

Les utilisateurs doivent télécharger le micrologiciel mis à jour pour se prémunir contre cette vulnérabilité potentielle. Il est disponible sur le site officiel de Hikvision.

Source d'informations sur la vulnérabilité

Cette vulnérabilité a été signalée à HSRC par Ori Hollander de VDOO Connected Trust LTD., Une société de sécurité israélienne spécialisée dans la sécurité IoT.

Contactez-nous

Si vous avez un problème de sécurité ou une préoccupation, veuillez contacter le Centre de réponse de sécurité Hikvision à l’adresse hsrc@hikvision.com.

Ce site web utilise des cookies pour stocker des informations sur votre appareil. Les cookies aident notre site web à fonctionner normalement et nous montrent comment nous pouvons améliorer votre expérience utilisateur.
En poursuivant votre navigation sur le site, vous acceptez nos politique relative aux cookies et politique de confidentialité.

Contactez-Nous